py27-visa (python/py-visa) Add to my watchlist

Python binding to VISA instrument protocol

PyVISA allows dialog between a computer and various engineering instruments such as oscilloscopes, spectrum analyzers, waveform generators, etc. using the VISA Framework of National Instruments, which must be installed independently. WARNING: VISA Frameworks prior to 14.0, (released 2014), are 32-bit only, so to be able to use py-visa on a 64-bit machine, you MUST EITHER install a 64-bit-compatible VISA version OR install a universal Python and execute python in 32-bit mode with ‘arch -i386’.

Version: 1.10.1 License: MIT
Maintainers No Maintainer
Categories science python
Homepage https://github.com/pyvisa/pyvisa
Platforms darwin
Variants -

Subport(s) (6)


"py27-visa" depends on

lib (6)
build (1)

Ports that depend on "py27-visa"



Port notes

If you are migrating from py-visa < 1.5, read https://pyvisa.readthedocs.org/en/stable/migrating.html
for possible compatibility issues.


Port Health:

Loading Port Health

Installations (30 days)

0

Requested Installations (30 days)

0

Livecheck error

Error: Port py27-visa not found

last updated: 4 hours ago