p5.32-moosex-role-strict

v 0.50.0 Updated: 1 year, 5 months ago

MooseX::Role::Strict - use strict 'roles'

WARNING: this is ALPHA code. More features to be added later. When using Moose::Role, a class which provides a method a role provides will silently override that method. This can cause strange, hard-to-debug errors when the role's methods are not called. Simple use MooseX::Role::Strict instead of Moose::Role and overriding a role's method becomes a composition-time failure.

https://metacpan.org/pod/MooseX::Role::Strict

To install p5.32-moosex-role-strict, paste this in macOS terminal after installing MacPorts

sudo port install p5.32-moosex-role-strict

Add to my watchlist

Installations 0
Requested Installations 0