py39-mpi4py (python/py-mpi4py) Add to my watchlist

MPI for Python - Python bindings for MPI

MPI for Python (mpi4py) provides bindings of the Message Passing Interface (MPI) standard for the Python programming language, allowing any Python program to exploit multiple processors. This package is constructed on top of the MPI-1/MPI-2 specification and provides an object oriented interface which closely follows MPI-2 C++ bindings. It supports point-to-point (sends, receives) and collective (broadcasts, scatters, gathers) communications of any picklable Python object as well as optimized communications of Python object exposing the single-segment buffer interface (NumPy arrays, builtin bytes/string/array objects).

Version: 3.0.3 License: BSD GitHub
Reset

31 build(s) found
Builder Build Number Start Time Elapsed Time Watcher Build Status
12 6752 2021-12-11 11:17:56 0:05:33 1723 build successful
12.arm64 20000 2021-11-18 15:27:37 0:01:19 1269 build successful
10.6 36038 2021-07-10 22:50:08 0:07:51 19807 build successful
10.6.x86_64 66590 2021-07-10 21:41:17 0:06:55 19780 build successful
10.6.x86_64 56236 2021-05-12 13:50:00 0:01:19 17785 failed install-dependencies
10.6 31233 2021-05-12 12:31:26 0:01:21 17817 failed install-dependencies
10.6 29786 2021-04-17 4:39:39 0:00:43 16936 failed install-dependencies
10.6.x86_64 53955 2021-04-17 4:14:05 0:01:06 16902 failed install-dependencies
10.6 29768 2021-04-17 0:05:54 0:00:45 16917 failed install-dependencies
10.6.x86_64 53907 2021-04-16 23:54:36 0:00:54 16883 failed install-dependencies
10.6 29762 2021-04-16 23:42:46 0:00:45 16916 failed install-dependencies
10.6.x86_64 53898 2021-04-16 23:31:36 0:00:59 16882 failed install-dependencies
10.6 29756 2021-04-16 23:08:17 0:00:54 16915 failed install-dependencies
10.6.x86_64 53889 2021-04-16 22:57:08 0:00:59 16881 failed install-dependencies
10.6 29680 2021-04-15 15:53:31 0:00:49 16855 failed install-dependencies
10.6.x86_64 53746 2021-04-15 15:40:04 0:00:37 16819 failed install-dependencies
10.6 29674 2021-04-15 14:33:46 0:00:55 16854 failed install-dependencies
10.6.x86_64 53737 2021-04-15 14:17:11 0:00:55 16818 failed install-dependencies
10.15 51543 2021-03-19 21:58:49 0:04:22 13413 build successful
10.9 138868 2021-02-20 18:21:15 0:04:58 42402 build successful
10.6.x86_64 48346 2021-02-14 12:32:55 0:00:41 14866 failed install-dependencies
10.14 79050 2021-02-09 10:50:49 0:05:14 24046 build successful
11 21076 2021-02-09 10:46:10 0:05:47 2839 build successful
10.11 133525 2021-02-09 10:45:44 0:04:54 42392 build successful
10.8 38148 2021-02-09 10:28:07 0:05:58 12702 build successful
10.6 26262 2021-02-09 9:50:12 0:00:53 14851 failed install-dependencies
10.7 44159 2021-02-09 6:57:55 0:05:05 14844 build successful
10.10 135024 2021-02-09 5:41:42 0:05:02 42450 build successful
10.13 103248 2021-02-09 4:08:46 0:05:34 33351 build successful
10.12 138495 2021-02-09 3:18:22 0:05:23 41385 build successful
11.arm64 11606 2021-02-09 1:05:29 0:01:49 2983 build successful