GET /api/v1/ports/py311-psycopg2/
HTTP 200 OK
Allow: GET, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
    "name": "py311-psycopg2",
    "portdir": "python/py-psycopg2",
    "version": "2.9.9",
    "license": "LGPL-3+",
    "platforms": "darwin freebsd",
    "epoch": 0,
    "replaced_by": null,
    "homepage": "https://www.psycopg.org",
    "description": "A python DBAPI-2.0-compliant database adapter for postgresql",
    "long_description": "Psycopg2 is a postgresql database adapter for python. It's fully compliant to python's DBAPI-2.0. psycopg is designed for heavily multi-threaded applications featuring connection pooling.",
    "active": true,
    "categories": [
        "databases",
        "python"
    ],
    "maintainers": [
        {
            "name": "snc",
            "github": "nerdling",
            "ports_count": 147
        }
    ],
    "variants": [
        "postgresql10",
        "postgresql11",
        "postgresql12",
        "postgresql13",
        "postgresql14",
        "postgresql15",
        "postgresql16"
    ],
    "dependencies": [
        {
            "type": "build",
            "ports": [
                "clang-16",
                "py311-installer",
                "py311-setuptools",
                "py311-wheel",
                "py311-virtualenv",
                "py311-build"
            ]
        },
        {
            "type": "lib",
            "ports": [
                "python311",
                "py311-setuptools",
                "postgresql16",
                "openssl"
            ]
        }
    ],
    "depends_on": [
        {
            "type": "run",
            "ports": [
                "grass7"
            ]
        }
    ]
}