GET /api/v1/ports/libcxx/
HTTP 200 OK
Allow: GET, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
    "name": "libcxx",
    "portdir": "lang/libcxx",
    "version": "5.0.1",
    "license": "MIT and NCSA",
    "platforms": "any",
    "epoch": 1,
    "replaced_by": null,
    "homepage": "https://libcxx.llvm.org/",
    "description": "libc++ is a new implementation of the C++ standard library with support for C++11 and portions of C++14.",
    "long_description": "libc++ is a new implementation of the C++ standard library with support for C++11 and portions of C++14. Because objects cannot be passed between different versions of the C++ runtime, this port must replace the host version in order to be used. On Snow Leopard and earlier, this is done automatically because there is no existing host version of this library. On Lion and later, users must build the port with +replacemnt_libcxx and install the root manually if they wish to replace the existing host implementation.",
    "active": true,
    "categories": [
        "lang"
    ],
    "maintainers": [
        {
            "name": "jeremyhu",
            "github": "jeremyhu",
            "ports_count": 259
        },
        {
            "name": "kirill",
            "github": "catap",
            "ports_count": 561
        }
    ],
    "variants": [
        "replacemnt_libcxx"
    ],
    "dependencies": [
        {
            "type": "build",
            "ports": [
                "clang-14"
            ]
        },
        {
            "type": "extract",
            "ports": [
                null
            ]
        }
    ],
    "depends_on": [
        {
            "type": "lib",
            "ports": [
                "ld64-274",
                "ld64-latest",
                "nodejs10",
                "nodejs12",
                "nodejs13",
                "nodejs15",
                "nodejs8",
                "llvm-11",
                "clang-11",
                "flang-11",
                "lldb-11",
                "llvm-12",
                "clang-12",
                "lldb-12",
                "llvm-13",
                "mlir-13",
                "clang-13",
                "lldb-13",
                "flang-13",
                "llvm-14",
                "mlir-14",
                "clang-14",
                "lldb-14",
                "flang-14",
                "llvm-3.7",
                "llvm-5.0",
                "clang-5.0",
                "lldb-5.0",
                "llvm-6.0",
                "clang-6.0",
                "lldb-6.0",
                "llvm-7.0",
                "clang-7.0",
                "lldb-7.0",
                "llvm-8.0",
                "clang-8.0",
                "lldb-8.0",
                "llvm-9.0",
                "clang-9.0",
                "lldb-9.0",
                "nodejs17",
                "llvm-devel",
                "mlir-devel",
                "clang-devel",
                "lldb-devel",
                "flang-devel",
                "nodejs14",
                "nodejs16",
                "llvm-15",
                "mlir-15",
                "cmake",
                "llvm-10",
                "clang-10",
                "lldb-10",
                "clang-15",
                "lldb-15",
                "flang-15",
                "retdec",
                "retdec-devel",
                "nodejs19",
                "nodejs18",
                "cmake-devel",
                "cmake-devel-gui",
                "cmake-devel-docs"
            ]
        }
    ]
}