GET /api/v1/ports/?format=api&page=196
HTTP 200 OK
Allow: GET, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
    "count": 53702,
    "next": "https://ports.macports.org/api/v1/ports/?format=api&page=197",
    "previous": "https://ports.macports.org/api/v1/ports/?format=api&page=195",
    "results": [
        {
            "name": "py312-pymunk",
            "portdir": "python/py-pymunk",
            "version": "6.6.0",
            "license": "MIT",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "http://www.pymunk.org/",
            "description": "Python wrapper around the 2d physics library Chipmunk",
            "long_description": "Python wrapper around the 2d physics library Chipmunk",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-setuptools",
                        "py312-build",
                        "py312-installer",
                        "clang-18",
                        "py312-wheel",
                        "py312-cffi"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py-pymunk"
                    ]
                }
            ]
        },
        {
            "name": "srgn",
            "portdir": "devel/srgn",
            "version": "0.14.2",
            "license": "MIT",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/alexpovel/srgn",
            "description": "A code surgeon for precise text and code transplantation. A marriage of `tr`/`sed`, `rg` and `tree-sitter`.",
            "long_description": "A code surgeon for precise text and code transplantation. A marriage of `tr`/`sed`, `rg` and `tree-sitter`.",
            "active": true,
            "categories": [
                "devel",
                "textproc"
            ],
            "maintainers": [
                {
                    "name": "herby.gillot",
                    "github": "herbygillot",
                    "ports_count": 1161
                }
            ],
            "variants": [
                "universal"
            ],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "cargo",
                        "legacy-support",
                        "rust",
                        "clang-20"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "libunwind"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-mslex",
            "portdir": "python/py-mslex",
            "version": "1.3.0",
            "license": "Apache-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/smoofra/mslex",
            "description": "Missing shlex package for windows shell quoting",
            "long_description": "Missing shlex package for windows shell quoting. It provides three functions - split, quote and join - just like shlex.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-setuptools",
                        "py312-build",
                        "py312-installer",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py312-pytest"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py311-mslex",
            "portdir": "python/py-mslex",
            "version": "1.3.0",
            "license": "Apache-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/smoofra/mslex",
            "description": "Missing shlex package for windows shell quoting",
            "long_description": "Missing shlex package for windows shell quoting. It provides three functions - split, quote and join - just like shlex.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py311-setuptools",
                        "py311-build",
                        "py311-installer",
                        "py311-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python311"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py311-pytest"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py310-mslex",
            "portdir": "python/py-mslex",
            "version": "1.3.0",
            "license": "Apache-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/smoofra/mslex",
            "description": "Missing shlex package for windows shell quoting",
            "long_description": "Missing shlex package for windows shell quoting. It provides three functions - split, quote and join - just like shlex.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py310-build",
                        "py310-setuptools",
                        "py310-wheel",
                        "py310-installer",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python310"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py310-pytest"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py39-mslex",
            "portdir": "python/py-mslex",
            "version": "1.1.0",
            "license": "Apache-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/smoofra/mslex",
            "description": "Missing shlex package for windows shell quoting",
            "long_description": "Missing shlex package for windows shell quoting. It provides three functions - split, quote and join - just like shlex.",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py39-build",
                        "py39-setuptools",
                        "py39-wheel",
                        "py39-installer",
                        "clang-17"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python39"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py39-pytest"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py-mslex",
            "portdir": "python/py-mslex",
            "version": "1.3.0",
            "license": "Apache-2",
            "platforms": "any",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/smoofra/mslex",
            "description": "Missing shlex package for windows shell quoting",
            "long_description": "Missing shlex package for windows shell quoting. It provides three functions - split, quote and join - just like shlex.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py314-mslex"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "R-secretbase",
            "portdir": "R/R-secretbase",
            "version": "1.0.3",
            "license": "GPL-3+",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://shikokuchuo.net/secretbase",
            "description": "Cryptographic hash and extendable-output functions",
            "long_description": "Cryptographic hash and extendable-output functions",
            "active": true,
            "categories": [
                "science",
                "crypto",
                "R"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "R",
                        "clang-19"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "R-CRAN-recommended"
                    ]
                },
                {
                    "type": "run",
                    "ports": [
                        "R"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "R-ichimoku",
                        "R-jagstargets",
                        "R-tarchetypes",
                        "R-targets"
                    ]
                }
            ]
        },
        {
            "name": "py312-aioitertools",
            "portdir": "python/py-aioitertools",
            "version": "0.13.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://aioitertools.omnilib.dev/",
            "description": "Async implementation of itertools, builtins and more.",
            "long_description": "Async implementation of itertools, builtins and more.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-flit_core",
                        "py312-installer",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-aiobotocore",
                        "py312-maggma"
                    ]
                }
            ]
        },
        {
            "name": "py312-aiobotocore",
            "portdir": "python/py-aiobotocore",
            "version": "2.26.0",
            "license": "Apache-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/aio-libs/aiobotocore",
            "description": "Async client for Amazon services",
            "long_description": "Async client for Amazon services",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-installer",
                        "py312-setuptools",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py312-botocore",
                        "python312",
                        "py312-aioitertools",
                        "py312-jmespath",
                        "py312-multidict",
                        "py312-dateutil",
                        "py312-aiohttp",
                        "py312-wrapt"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-s3fs"
                    ]
                }
            ]
        },
        {
            "name": "ugit",
            "portdir": "devel/ugit",
            "version": "5.9",
            "license": "MIT",
            "platforms": "any",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://bhupesh.me/undo-your-last-git-mistake-with-ugit/",
            "description": "ugit helps undo git commands",
            "long_description": "ugit helps undo git commands. ugit/git-undo supports undoing the following operations, some are a WIP: git commit, git add, git push, git branch -D (branch delete), git pull, git reset, git tag -d (tag delete), git stash apply, git stash pop/drop/clear, accidental file delete (Restore a deleted file after a commit), (Restore) a file to a previous version, git merge, git cherry-pick, and git tag.",
            "active": true,
            "categories": [
                "devel"
            ],
            "maintainers": [
                {
                    "name": "herby.gillot",
                    "github": "herbygillot",
                    "ports_count": 1161
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "bash"
                    ]
                },
                {
                    "type": "run",
                    "ports": [
                        "git",
                        "fzf"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "gitoxide",
            "portdir": "devel/gitoxide",
            "version": "0.61.0",
            "license": "(Apache-2 or MIT)",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/GitoxideLabs/gitoxide",
            "description": "An idiomatic, lean, fast & safe pure Rust implementation of Git",
            "long_description": "gitoxide is an implementation of git written in Rust for developing future-proof applications which strive for correctness and performance while providing a pleasant and unsurprising developer experience.",
            "active": true,
            "categories": [
                "devel"
            ],
            "maintainers": [
                {
                    "name": "herby.gillot",
                    "github": "herbygillot",
                    "ports_count": 1161
                }
            ],
            "variants": [
                "universal"
            ],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-20",
                        "pkgconfig",
                        "rust",
                        "cargo",
                        "cmake",
                        "legacy-support"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "curl",
                        "libunwind"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-redis",
            "portdir": "python/py-redis",
            "version": "7.1.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/redis/redis-py",
            "description": "Python client for Redis key-value store",
            "long_description": "Python client for Redis key-value store",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-installer",
                        "py312-hatchling",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "run",
                    "ports": [
                        "py312-spotipy"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py312-portalocker"
                    ]
                }
            ]
        },
        {
            "name": "py312-pymongo",
            "portdir": "python/py-pymongo",
            "version": "4.12.0",
            "license": "Apache",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://www.mongodb.org/",
            "description": "Python access to MongoDB",
            "long_description": "The PyMongo distribution contains tools for interacting with the Mongo database from Python.",
            "active": true,
            "categories": [
                "databases",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [
                "universal"
            ],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-installer",
                        "clang-18",
                        "py312-hatch-requirements-txt",
                        "py312-build",
                        "py312-hatchling"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py312-dnspython",
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-maggma"
                    ]
                }
            ]
        },
        {
            "name": "py312-path",
            "portdir": "python/py-path",
            "version": "17.1.1",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/jaraco/path",
            "description": "Object-oriented file system path manipulation",
            "long_description": "path (aka path pie, formerly path.py) implements path objects as first-class entities, allowing common operations on files to be invoked on those path objects directly.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-coherent.licensed",
                        "py312-build",
                        "py312-installer",
                        "py312-setuptools",
                        "py312-wheel",
                        "py312-setuptools_scm",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py312-more-itertools",
                        "py312-pytest"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "run",
                    "ports": [
                        "py312-pytest-shutil"
                    ]
                }
            ]
        },
        {
            "name": "py312-async-lru",
            "portdir": "python/py-async-lru",
            "version": "2.3.0",
            "license": "BSD",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/aio-libs/async-lru",
            "description": "A port of Python’s built-in functools.lru_cache function for asyncio",
            "long_description": "A port of Python’s built-in functools.lru_cache function for asyncio",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-installer",
                        "py312-setuptools",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-jupyterlab"
                    ]
                }
            ]
        },
        {
            "name": "py312-jug",
            "portdir": "python/py-jug",
            "version": "2.4.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://jug.readthedocs.io/",
            "description": "A Task Based Parallelization Framework",
            "long_description": "A Task Based Parallelization Framework",
            "active": true,
            "categories": [
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-installer",
                        "py312-setuptools",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-iso8601",
            "portdir": "python/py-iso8601",
            "version": "2.1.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/micktwomey/pyiso8601",
            "description": "Simple module to parse ISO 8601 dates",
            "long_description": "Simple module to parse ISO 8601 dates",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-poetry-core",
                        "py312-build",
                        "py312-installer",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py312-hypothesis",
                        "py312-pytest"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-colander"
                    ]
                },
                {
                    "type": "run",
                    "ports": [
                        "py312-keystoneauth1",
                        "py312-openstackclient",
                        "py312-openstacksdk",
                        "py312-oslo-utils",
                        "py312-novaclient"
                    ]
                }
            ]
        },
        {
            "name": "py312-uri-template",
            "portdir": "python/py-uri-template",
            "version": "1.3.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://gitlab.linss.com/open-source/python/uri-template",
            "description": "RFC 6570 URI Template Processor",
            "long_description": "RFC 6570 URI Template Processor",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-setuptools",
                        "py312-build",
                        "py312-installer",
                        "clang-18",
                        "py312-wheel",
                        "py312-setuptools_scm"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py311-uri-template",
            "portdir": "python/py-uri-template",
            "version": "1.3.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://gitlab.linss.com/open-source/python/uri-template",
            "description": "RFC 6570 URI Template Processor",
            "long_description": "RFC 6570 URI Template Processor",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py311-setuptools",
                        "py311-build",
                        "py311-installer",
                        "clang-18",
                        "py311-wheel",
                        "py311-setuptools_scm"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python311"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py311-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py310-uri-template",
            "portdir": "python/py-uri-template",
            "version": "1.3.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://gitlab.linss.com/open-source/python/uri-template",
            "description": "RFC 6570 URI Template Processor",
            "long_description": "RFC 6570 URI Template Processor",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py310-wheel",
                        "py310-setuptools",
                        "py310-setuptools_scm",
                        "clang-18",
                        "py310-build",
                        "py310-installer"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python310"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py310-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py39-uri-template",
            "portdir": "python/py-uri-template",
            "version": "1.3.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://gitlab.linss.com/open-source/python/uri-template",
            "description": "RFC 6570 URI Template Processor",
            "long_description": "RFC 6570 URI Template Processor",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py39-wheel",
                        "py39-setuptools",
                        "py39-setuptools_scm",
                        "clang-18",
                        "py39-build",
                        "py39-installer"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python39"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py39-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py38-uri-template",
            "portdir": "python/py-uri-template",
            "version": "1.3.0",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://gitlab.linss.com/open-source/python/uri-template",
            "description": "RFC 6570 URI Template Processor",
            "long_description": "RFC 6570 URI Template Processor",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py38-wheel",
                        "py38-setuptools",
                        "py38-setuptools_scm",
                        "clang-17",
                        "py38-build",
                        "py38-installer"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python38"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py38-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py-uri-template",
            "portdir": "python/py-uri-template",
            "version": "1.3.0",
            "license": "MIT",
            "platforms": "any",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://gitlab.linss.com/open-source/python/uri-template",
            "description": "RFC 6570 URI Template Processor",
            "long_description": "RFC 6570 URI Template Processor",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py314-uri-template"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-rfc3986-validator",
            "portdir": "python/py-rfc3986-validator",
            "version": "0.1.1",
            "license": "BSD",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/naimetti/rfc3986-validator",
            "description": "A pure python RFC3986 validator",
            "long_description": "A pure python RFC3986 validator",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-setuptools",
                        "py312-build",
                        "py312-installer",
                        "clang-18",
                        "py312-wheel",
                        "py312-pytest-runner"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-jsonschema-format-nongpl",
                        "py312-jupyter_events"
                    ]
                }
            ]
        },
        {
            "name": "py312-jsonpointer",
            "portdir": "python/py-jsonpointer",
            "version": "3.8",
            "license": "BSD",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/stefankoegl/python-json-pointer",
            "description": "Identify specific nodes in a JSON document (RFC 6901)",
            "long_description": "Identify specific nodes in a JSON document (RFC 6901)",
            "active": true,
            "categories": [
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-setuptools",
                        "py312-build",
                        "py312-installer",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py312-pytest"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-jsonschema-format-nongpl"
                    ]
                },
                {
                    "type": "run",
                    "ports": [
                        "py312-jsonpatch",
                        "py312-sphinx-jsonschema"
                    ]
                }
            ]
        },
        {
            "name": "py312-isoduration",
            "portdir": "python/py-isoduration",
            "version": "20.11.0",
            "license": "ISC",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/bolsote/isoduration",
            "description": "Operations with ISO 8601 durations",
            "long_description": "Operations with ISO 8601 durations",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-installer",
                        "py312-wheel",
                        "clang-18",
                        "py312-build",
                        "py312-setuptools"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py312-arrow",
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py311-isoduration",
            "portdir": "python/py-isoduration",
            "version": "20.11.0",
            "license": "ISC",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/bolsote/isoduration",
            "description": "Operations with ISO 8601 durations",
            "long_description": "Operations with ISO 8601 durations",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py311-installer",
                        "py311-wheel",
                        "clang-18",
                        "py311-build",
                        "py311-setuptools"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py311-arrow",
                        "python311"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py311-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py310-isoduration",
            "portdir": "python/py-isoduration",
            "version": "20.11.0",
            "license": "ISC",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/bolsote/isoduration",
            "description": "Operations with ISO 8601 durations",
            "long_description": "Operations with ISO 8601 durations",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py310-wheel",
                        "py310-installer",
                        "clang-18",
                        "py310-setuptools",
                        "py310-build"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py310-arrow",
                        "python310"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py310-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py39-isoduration",
            "portdir": "python/py-isoduration",
            "version": "20.11.0",
            "license": "ISC",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/bolsote/isoduration",
            "description": "Operations with ISO 8601 durations",
            "long_description": "Operations with ISO 8601 durations",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py39-wheel",
                        "py39-installer",
                        "clang-18",
                        "py39-setuptools",
                        "py39-build"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py39-arrow",
                        "python39"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py39-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py38-isoduration",
            "portdir": "python/py-isoduration",
            "version": "20.11.0",
            "license": "ISC",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/bolsote/isoduration",
            "description": "Operations with ISO 8601 durations",
            "long_description": "Operations with ISO 8601 durations",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py38-wheel",
                        "py38-installer",
                        "clang-17",
                        "py38-setuptools",
                        "py38-build"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py38-arrow",
                        "python38"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py38-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py-isoduration",
            "portdir": "python/py-isoduration",
            "version": "20.11.0",
            "license": "ISC",
            "platforms": "any",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/bolsote/isoduration",
            "description": "Operations with ISO 8601 durations",
            "long_description": "Operations with ISO 8601 durations",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py314-isoduration"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-fqdn",
            "portdir": "python/py-fqdn",
            "version": "1.6.0",
            "license": "MPL-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ypcrts/fqdn",
            "description": "Validates fully-qualified domain names against RFC 1123",
            "long_description": "Validates fully-qualified domain names against RFC 1123",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-setuptools",
                        "py312-build",
                        "py312-installer",
                        "clang-18",
                        "py312-wheel",
                        "py312-setuptools_scm"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py311-fqdn",
            "portdir": "python/py-fqdn",
            "version": "1.6.0",
            "license": "MPL-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ypcrts/fqdn",
            "description": "Validates fully-qualified domain names against RFC 1123",
            "long_description": "Validates fully-qualified domain names against RFC 1123",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py311-setuptools",
                        "py311-build",
                        "py311-installer",
                        "clang-18",
                        "py311-wheel",
                        "py311-setuptools_scm"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python311"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py311-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py310-fqdn",
            "portdir": "python/py-fqdn",
            "version": "1.6.0",
            "license": "MPL-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ypcrts/fqdn",
            "description": "Validates fully-qualified domain names against RFC 1123",
            "long_description": "Validates fully-qualified domain names against RFC 1123",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py310-wheel",
                        "py310-setuptools",
                        "py310-setuptools_scm",
                        "clang-18",
                        "py310-build",
                        "py310-installer"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python310"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py310-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py39-fqdn",
            "portdir": "python/py-fqdn",
            "version": "1.5.1",
            "license": "MPL-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ypcrts/fqdn",
            "description": "Validates fully-qualified domain names against RFC 1123",
            "long_description": "Validates fully-qualified domain names against RFC 1123",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py39-setuptools",
                        "py39-wheel",
                        "py39-build",
                        "py39-installer",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python39"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py39-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py38-fqdn",
            "portdir": "python/py-fqdn",
            "version": "1.5.1",
            "license": "MPL-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ypcrts/fqdn",
            "description": "Validates fully-qualified domain names against RFC 1123",
            "long_description": "Validates fully-qualified domain names against RFC 1123",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py38-setuptools",
                        "py38-wheel",
                        "py38-build",
                        "py38-installer",
                        "clang-17"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python38"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py38-jsonschema-format-nongpl"
                    ]
                }
            ]
        },
        {
            "name": "py-fqdn",
            "portdir": "python/py-fqdn",
            "version": "1.6.0",
            "license": "MPL-2",
            "platforms": "any",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ypcrts/fqdn",
            "description": "Validates fully-qualified domain names against RFC 1123",
            "long_description": "Validates fully-qualified domain names against RFC 1123",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py314-fqdn"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-alembic",
            "portdir": "python/py-alembic",
            "version": "1.17.2",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://alembic.sqlalchemy.org/",
            "description": "A database migration tool for SQLAlchemy.",
            "long_description": "A database migration tool for SQLAlchemy.",
            "active": true,
            "categories": [
                "databases",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-18",
                        "py312-build",
                        "py312-installer",
                        "py312-setuptools",
                        "py312-wheel"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py312-typing_extensions",
                        "py312-sqlalchemy",
                        "py312-mako",
                        "python312"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-xkcdpass",
            "portdir": "python/py-xkcdpass",
            "version": "1.30.0",
            "license": "BSD",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/redacted/XKCD-password-generator",
            "description": "A flexible and scriptable password generator which generates strong passphrases, inspired by XKCD 936",
            "long_description": "A flexible and scriptable password generator which generates strong passphrases, inspired by XKCD 936",
            "active": true,
            "categories": [
                "security",
                "python"
            ],
            "maintainers": [
                {
                    "name": "amake",
                    "github": "amake",
                    "ports_count": 166
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-setuptools",
                        "py312-build",
                        "py312-installer",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "py312-pytest"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py38-descartes",
            "portdir": "python/py-descartes",
            "version": "1.1.0",
            "license": "BSD",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://bitbucket.org/sgillies/descartes/",
            "description": "Use geometric objects as matplotlib paths and patches",
            "long_description": "Use geometric objects as matplotlib paths and patches",
            "active": false,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "stromnov",
                    "github": "stromnov",
                    "ports_count": 2959
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-16",
                        "py38-wheel",
                        "py38-build",
                        "py38-installer",
                        "py38-setuptools"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py38-matplotlib",
                        "py38-numpy",
                        "python38"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py-descartes"
                    ]
                }
            ]
        },
        {
            "name": "py312-resolvelib",
            "portdir": "python/py-resolvelib",
            "version": "1.2.1",
            "license": "ISC",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/sarugaku/resolvelib",
            "description": "ResolveLib at the highest level provides a Resolver class that includes dependency resolution logic.",
            "long_description": "ResolveLib at the highest level provides a Resolver class that includes dependency resolution logic. You give it some things, and a little information on how it should interact with them, and it will spit out a resolution result.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-installer",
                        "py312-wheel",
                        "clang-18",
                        "py312-build",
                        "py312-setuptools"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py312-setuptools",
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-ansible-core"
                    ]
                }
            ]
        },
        {
            "name": "py312-ansible-core",
            "portdir": "python/py-ansible-core",
            "version": "2.20.0",
            "license": "GPL-3+",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ansible/ansible",
            "description": "SSH-based configuration management and deployment system",
            "long_description": "Ansible is a radically simple model-driven configuration management, multi-node deployment, and remote task execution system. Ansible works over SSH and does not require any software or daemons to be installed on remote nodes. Extension modules can be written in any language and are transferred to managed machines automatically.",
            "active": true,
            "categories": [
                "sysutils",
                "python"
            ],
            "maintainers": [
                {
                    "name": "adfernandes",
                    "github": "adfernandes",
                    "ports_count": 47
                },
                {
                    "name": "pedro.salgado",
                    "github": "steenzout",
                    "ports_count": 54
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-installer",
                        "py312-setuptools",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py312-six",
                        "py312-cryptography",
                        "py312-yaml",
                        "ansible_select",
                        "py312-paramiko",
                        "py312-resolvelib",
                        "py312-httplib2",
                        "python312",
                        "py312-packaging",
                        "py312-setuptools",
                        "py312-jinja2"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-ansible"
                    ]
                }
            ]
        },
        {
            "name": "py312-ansible",
            "portdir": "python/py-ansible",
            "version": "13.0.0",
            "license": "GPL-3+",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/ansible/ansible",
            "description": "SSH-based configuration management and deployment system",
            "long_description": "Ansible is a radically simple model-driven configuration management, multi-node deployment, and remote task execution system. Ansible works over SSH and does not require any software or daemons to be installed on remote nodes. Extension modules can be written in any language and are transferred to managed machines automatically.",
            "active": true,
            "categories": [
                "sysutils",
                "python"
            ],
            "maintainers": [
                {
                    "name": "adfernandes",
                    "github": "adfernandes",
                    "ports_count": 47
                },
                {
                    "name": "pedro.salgado",
                    "github": "steenzout",
                    "ports_count": 54
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-installer",
                        "py312-wheel",
                        "clang-18",
                        "py312-build",
                        "py312-setuptools"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "py312-ansible-core",
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-mitogen"
                    ]
                }
            ]
        },
        {
            "name": "iv",
            "portdir": "devel/iv",
            "version": "2015.03.24",
            "license": "BSD",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/Constellation/iv",
            "description": "iv is ECMA262 5.1 lexer and parser and engine project",
            "long_description": "iv is ECMA262 5.1 lexer and parser and engine project written in C++/JS.",
            "active": true,
            "categories": [
                "devel"
            ],
            "maintainers": [],
            "variants": [
                "debug"
            ],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "cmake",
                        "clang-18"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "picotls",
            "portdir": "net/picotls",
            "version": "2025.09.12",
            "license": "MIT",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/h2o/picotls",
            "description": "picotls is a TLS 1.3 (RFC 8446) protocol stack written in C",
            "long_description": "picotls is a TLS 1.3 (RFC 8446) protocol stack written in C. &{name} is designed to be fast, tiny and low-latency, with the primary user being the H2O HTTP/2 server for serving HTTP/1, HTTP/2 and HTTP/3 over QUIC.",
            "active": true,
            "categories": [
                "net",
                "security"
            ],
            "maintainers": [],
            "variants": [
                "debug",
                "universal"
            ],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "pkgconfig",
                        "cmake",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "brotli",
                        "openssl3"
                    ]
                },
                {
                    "type": "test",
                    "ports": [
                        "p5.34-test-tcp",
                        "p5.34-scope-guard"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "lpython",
            "portdir": "lang/lpython",
            "version": "0.20.0",
            "license": "BSD",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://lpython.org",
            "description": "High-performance typed Python compiler",
            "long_description": "LPython aggressively optimizes type-annotated Python code. It has several backends, including LLVM, C, C++ and WASM. LPython’s primary tenet is speed.",
            "active": true,
            "categories": [
                "lang",
                "python"
            ],
            "maintainers": [],
            "variants": [
                "debug",
                "universal"
            ],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "clang-20",
                        "bison",
                        "cmake",
                        "re2c",
                        "bash"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "rapidjson",
                        "libfmt10",
                        "python312",
                        "zlib"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "haskell-language-server",
            "portdir": "devel/haskell-language-server",
            "version": "2.14.0.0",
            "license": "GPL-3",
            "platforms": "darwin",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/haskell/haskell-language-server",
            "description": "Official haskell ide support via language server (LSP).",
            "long_description": "The haskell-language-server (HLS) project is an implementation of a server (a \"language server\") for the Language Server Protocol (LSP). A language server talks to a client (typically an editor), which can ask the server to perform various operations, such as reporting errors or providing code completions. The advantage of this system is that clients and servers can interoperate more easily so long as they all speak the LSP protocol. In the case of HLS, that means that it can be used with many different editors, since editor support for the LSP protocol is now widespread.",
            "active": true,
            "categories": [
                "devel",
                "haskell"
            ],
            "maintainers": [],
            "variants": [
                "dynamic"
            ],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "file",
                        "grep",
                        "gsed",
                        "clang-18",
                        "cctools",
                        "openssl",
                        "cabal",
                        "ghc"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "gmp",
                        "ghc",
                        "libiconv"
                    ]
                },
                {
                    "type": "patch",
                    "ports": [
                        "cabal"
                    ]
                },
                {
                    "type": "run",
                    "ports": [
                        "hscolour",
                        "cabal"
                    ]
                }
            ],
            "depends_on": []
        },
        {
            "name": "py312-invoke",
            "portdir": "python/py-invoke",
            "version": "3.0.3",
            "license": "Apache-2",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://pyinvoke.org/",
            "description": "Task execution tool and library for Python.",
            "long_description": "Invoke is a Python (2.7 and 3.4+) library for managing shell-oriented subprocesses and organizing executable Python code into CLI-invokable tasks. It draws inspiration from various sources (make/rake, Fabric 1.x, etc) to arrive at a powerful & clean feature set.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [
                {
                    "name": "danchr",
                    "github": "danchr",
                    "ports_count": 181
                }
            ],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-installer",
                        "py312-setuptools",
                        "py312-wheel",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py312-fabric"
                    ]
                }
            ]
        },
        {
            "name": "py312-backoff",
            "portdir": "python/py-backoff",
            "version": "2.2.1",
            "license": "MIT",
            "platforms": "{darwin any}",
            "epoch": 0,
            "replaced_by": null,
            "homepage": "https://github.com/litl/backoff",
            "description": "Function decoration for backoff and retry",
            "long_description": "This module provides function decorators which can be used to wrap a function such that it will be retried until some condition is met. It is meant to be of use when accessing unreliable resources with the potential for intermittent failures i.e. network resources and external APIs. Somewhat more generally, it may also be of use for dynamically polling resources for externally generated content.",
            "active": true,
            "categories": [
                "devel",
                "python"
            ],
            "maintainers": [],
            "variants": [],
            "dependencies": [
                {
                    "type": "build",
                    "ports": [
                        "py312-build",
                        "py312-installer",
                        "py312-poetry-core",
                        "clang-18"
                    ]
                },
                {
                    "type": "lib",
                    "ports": [
                        "python312"
                    ]
                }
            ],
            "depends_on": [
                {
                    "type": "lib",
                    "ports": [
                        "py-backoff"
                    ]
                }
            ]
        }
    ]
}