HTTP 200 OK
Allow: GET, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept
{
"count": 42547,
"next": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=590",
"previous": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=588",
"results": [
{
"name": "py313-repoze.sphinx.autointerface",
"description": "An extension for the Sphinx documentation system to allow generation of API documentation by introspection of zope.interface instances in code."
},
{
"name": "py313-reproject",
"description": "Astropy affiliated package for image reprojection"
},
{
"name": "py313-requests",
"description": "Python HTTP for Humans."
},
{
"name": "py313-requests-cache",
"description": "Transparent persistent cache for py-requests"
},
{
"name": "py313-requests-file",
"description": "Requests-File is a transport adapter for use with the Requests Python library to allow local filesystem access via file:// URLs."
},
{
"name": "py313-requests-futures",
"description": "Small add-on for the python requests http library."
},
{
"name": "py313-requests-gssapi",
"description": "requests GSSAPI authentication library"
},
{
"name": "py313-requests-kerberos",
"description": "A Kerberos authentication handler for python-requests"
},
{
"name": "py313-requests-mock",
"description": "Mock out responses from the requests package"
},
{
"name": "py313-requests-oauthlib",
"description": "OAuth for Humans"
},
{
"name": "py313-requests-toolbelt",
"description": "Collection of utilities for python-requests"
},
{
"name": "py313-requests-unixsocket",
"description": "HTTP via a UNIX domain socket"
},
{
"name": "py313-requests_ntlm",
"description": "NTLM authentication support for Requests"
},
{
"name": "py313-requestsexceptions",
"description": "A simple library to find the correct path to exceptions in the requests library regardless of whether they are bundled."
},
{
"name": "py313-requirements-parser",
"description": "Parses Pip requirement files"
},
{
"name": "py313-resampy",
"description": "Efficient sample rate conversion in python"
},
{
"name": "py313-resolvelib",
"description": "ResolveLib at the highest level provides a Resolver class that includes dependency resolution logic."
},
{
"name": "py313-responses",
"description": "A utility library for mocking out the requests library"
},
{
"name": "py313-resumable-urlretrieve",
"description": "Small library to fetch files over HTTP and resuming their download"
},
{
"name": "py313-retrying",
"description": "General-purpose retrying library for Python"
},
{
"name": "py313-rfc3339-validator",
"description": "A pure python RFC3339 validator"
},
{
"name": "py313-rfc3986",
"description": "A Python implementation of RFC 3986 including validation and authority parsing."
},
{
"name": "py313-rfc3986-validator",
"description": "A pure python RFC3986 validator"
},
{
"name": "py313-rfc3987-syntax",
"description": "Helper functions to parse and validate the syntax of terms defined in RFC 3987 — the IETF standard for Internationalized Resource Identifiers (IRIs)."
},
{
"name": "py313-rfc6555",
"description": "Python implementation of RFC 6555."
},
{
"name": "py313-rich",
"description": "Python library for rich text and beautiful formatting in the terminal"
},
{
"name": "py313-rich-argparse",
"description": "Format argparse and optparse help using rich"
},
{
"name": "py313-rich-click",
"description": "Format click help output nicely with rich"
},
{
"name": "py313-rich-theme-manager",
"description": "Manage rich themes for CLI applications"
},
{
"name": "py313-rich_rst",
"description": "reStructuredText renderer for rich"
},
{
"name": "py313-rlpycairo",
"description": "This is a plugin for the ReportLab PDF Toolkit."
},
{
"name": "py313-robotframework",
"description": "ATDD framework"
},
{
"name": "py313-robotframework-pythonlibcore",
"description": "Tools to ease creating larger test libraries for Robot Framework"
},
{
"name": "py313-robotframework-retryfailed",
"description": "Retry failed Robot Framework tests"
},
{
"name": "py313-robotframework-ride",
"description": "Robot Framework test case editor"
},
{
"name": "py313-robotframework-selenium2library",
"description": "Robot Framework library to run web-based tests"
},
{
"name": "py313-robotframework-seleniumlibrary",
"description": "Robot Framework library to run web-based tests"
},
{
"name": "py313-robotframework-sshlibrary",
"description": "Robot Framework library to handle SSH"
},
{
"name": "py313-roman",
"description": "Integer to Roman numerals converter"
},
{
"name": "py313-roman_numerals",
"description": "Manipulate well-formed Roman numerals"
},
{
"name": "py313-roman_numerals_py",
"description": "Obsolete port, replaced by py313-roman_numerals"
},
{
"name": "py313-roocode-code-indexer-macos",
"description": "High-performance OpenAI-compatible embedding server on Apple Silicon"
},
{
"name": "py313-rope",
"description": "python refactoring library"
},
{
"name": "py313-rpds-py",
"description": "Python bindings to Rust's persistent data structures (rpds)"
},
{
"name": "py313-rpy2",
"description": "A simple and efficient access to R from Python"
},
{
"name": "py313-rpy2-rinterface",
"description": "Low-level interface from Python to the R."
},
{
"name": "py313-rpy2-robjects",
"description": "Python interface to the R language (embedded R)"
},
{
"name": "py313-rsa",
"description": "Pure Python RSA implementation"
},
{
"name": "py313-rsgislib",
"description": "Python 3.13 bindings for RSGISlib - Remote Sensing and GIS Library"
},
{
"name": "py313-rstcheck",
"description": "Checks syntax of reStructuredText and code blocks nested within it"
}
]
}