HTTP 200 OK
Allow: GET, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept
{
"count": 42547,
"next": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=556",
"previous": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=554",
"results": [
{
"name": "py312-requests-toolbelt",
"description": "Collection of utilities for python-requests"
},
{
"name": "py312-requests-unixsocket",
"description": "HTTP via a UNIX domain socket"
},
{
"name": "py312-requests_ntlm",
"description": "NTLM authentication support for Requests"
},
{
"name": "py312-requestsexceptions",
"description": "A simple library to find the correct path to exceptions in the requests library regardless of whether they are bundled."
},
{
"name": "py312-resampy",
"description": "Efficient sample rate conversion in python"
},
{
"name": "py312-resolvelib",
"description": "ResolveLib at the highest level provides a Resolver class that includes dependency resolution logic."
},
{
"name": "py312-responses",
"description": "A utility library for mocking out the requests library"
},
{
"name": "py312-resumable-urlretrieve",
"description": "Small library to fetch files over HTTP and resuming their download"
},
{
"name": "py312-retrying",
"description": "General-purpose retrying library for Python"
},
{
"name": "py312-rfc3339-validator",
"description": "A pure python RFC3339 validator"
},
{
"name": "py312-rfc3986",
"description": "A Python implementation of RFC 3986 including validation and authority parsing."
},
{
"name": "py312-rfc3986-validator",
"description": "A pure python RFC3986 validator"
},
{
"name": "py312-rfc3987-syntax",
"description": "Helper functions to parse and validate the syntax of terms defined in RFC 3987 — the IETF standard for Internationalized Resource Identifiers (IRIs)."
},
{
"name": "py312-rfc6555",
"description": "Python implementation of RFC 6555."
},
{
"name": "py312-rich",
"description": "Python library for rich text and beautiful formatting in the terminal"
},
{
"name": "py312-rich-argparse",
"description": "Format argparse and optparse help using rich"
},
{
"name": "py312-rich-click",
"description": "Format click help output nicely with rich"
},
{
"name": "py312-rich-theme-manager",
"description": "Manage rich themes for CLI applications"
},
{
"name": "py312-rich_rst",
"description": "reStructuredText renderer for rich"
},
{
"name": "py312-rlpycairo",
"description": "This is a plugin for the ReportLab PDF Toolkit."
},
{
"name": "py312-robotframework",
"description": "ATDD framework"
},
{
"name": "py312-roman",
"description": "Integer to Roman numerals converter"
},
{
"name": "py312-roman_numerals",
"description": "Manipulate well-formed Roman numerals"
},
{
"name": "py312-roman_numerals_py",
"description": "Obsolete port, replaced by py312-roman_numerals"
},
{
"name": "py312-roocode-code-indexer-macos",
"description": "High-performance OpenAI-compatible embedding server on Apple Silicon"
},
{
"name": "py312-rope",
"description": "python refactoring library"
},
{
"name": "py312-rpds-py",
"description": "Python bindings to Rust's persistent data structures (rpds)"
},
{
"name": "py312-rsa",
"description": "Pure Python RSA implementation"
},
{
"name": "py312-rsgislib",
"description": "Python 3.12 bindings for RSGISlib - Remote Sensing and GIS Library"
},
{
"name": "py312-rstcheck",
"description": "Checks syntax of reStructuredText and code blocks nested within it"
},
{
"name": "py312-rstcheck-core",
"description": "Checks syntax of reStructuredText and code blocks nested within it"
},
{
"name": "py312-rtree",
"description": "R-Tree spatial index for Python GIS"
},
{
"name": "py312-ruamel-yaml",
"description": "YAML 1.2 loader/dumper package for Python"
},
{
"name": "py312-ruamel-yaml-clib",
"description": "the C based reader/scanner and emitter for ruamel.yaml"
},
{
"name": "py312-rubicon-objc",
"description": "Rubicon-ObjC is a bridge between Objective-C and Python"
},
{
"name": "py312-rustworkx",
"description": "A high performance Python graph library implemented in Rust"
},
{
"name": "py312-s3fs",
"description": "Convenient Filesystem interface over S3"
},
{
"name": "py312-s3transfer",
"description": "An Amazon S3 Transfer Manager"
},
{
"name": "py312-sacrebleu",
"description": "Hassle-free computation of shareable, comparable, and reproducible BLEU, chrF, and TER scores"
},
{
"name": "py312-sacremoses",
"description": "Python port of Moses tokenizer, truecaser and normalizer"
},
{
"name": "py312-safe-netrc",
"description": "Safe netrc file parser"
},
{
"name": "py312-safetensors",
"description": "Fast and Safe Tensor serialization"
},
{
"name": "py312-samplerate",
"description": "Monolithic python wrapper for libsamplerate based on pybind11 and NumPy"
},
{
"name": "py312-sarif-om",
"description": "Classes implementing the SARIF 2.1.0 object model."
},
{
"name": "py312-sarpy",
"description": "Tools to read, write, and process complex SAR data and associated data."
},
{
"name": "py312-scamper",
"description": "Python 3.12 bindings for scamper"
},
{
"name": "py312-scapy",
"description": "A powerful packet manipulation tool"
},
{
"name": "py312-schema",
"description": "Simple data validation library"
},
{
"name": "py312-scikit-build",
"description": "Improved build system generator for CPython extensions."
},
{
"name": "py312-scikit-build-core",
"description": "A bridge between Python package build systems and CMake (a rewrite of the classic Scikit-build)."
}
]
}