HTTP 200 OK
Allow: GET, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept
{
"count": 42547,
"next": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=521",
"previous": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=519",
"results": [
{
"name": "py311-rawpy",
"description": "Python wrapper for the LibRaw library"
},
{
"name": "py311-rchitect",
"description": "Mapping R API to Python"
},
{
"name": "py311-rdflib",
"description": "Python library for working with RDF"
},
{
"name": "py311-re2",
"description": "Python wrapper of Google's RE2 library."
},
{
"name": "py311-readability-lxml",
"description": "fast html to text parser (article readability tool)"
},
{
"name": "py311-readme_renderer",
"description": "Safely render long_description/README files in Warehouse"
},
{
"name": "py311-recommonmark",
"description": "Enables writing CommonMark inside of Docutils & Sphinx projects."
},
{
"name": "py311-redis",
"description": "Python client for Redis key-value store"
},
{
"name": "py311-reedsolo",
"description": "A pythonic universal errors-and-erasures Reed-Solomon Codec to protect your data from errors and bitrot."
},
{
"name": "py311-referencing",
"description": "JSON referencing + Python"
},
{
"name": "py311-reflink",
"description": "Python reflink wraps around platform specific reflink implementations"
},
{
"name": "py311-regex",
"description": "Alternate regular expression module, to replace re."
},
{
"name": "py311-regions",
"description": "Astropy affilated package for region handling"
},
{
"name": "py311-rencode",
"description": "Python module for fast (basic) object serialization similar to bencode"
},
{
"name": "py311-repl",
"description": "readline-a-like in Python"
},
{
"name": "py311-reportlab",
"description": "Engine for creating PDF documents"
},
{
"name": "py311-repoze.sphinx.autointerface",
"description": "An extension for the Sphinx documentation system to allow generation of API documentation by introspection of zope.interface instances in code."
},
{
"name": "py311-reproject",
"description": "Astropy affiliated package for image reprojection"
},
{
"name": "py311-requests",
"description": "Python HTTP for Humans."
},
{
"name": "py311-requests-cache",
"description": "Transparent persistent cache for py-requests"
},
{
"name": "py311-requests-file",
"description": "Requests-File is a transport adapter for use with the Requests Python library to allow local filesystem access via file:// URLs."
},
{
"name": "py311-requests-futures",
"description": "Small add-on for the python requests http library."
},
{
"name": "py311-requests-kerberos",
"description": "A Kerberos authentication handler for python-requests"
},
{
"name": "py311-requests-mock",
"description": "Mock out responses from the requests package"
},
{
"name": "py311-requests-oauthlib",
"description": "OAuth for Humans"
},
{
"name": "py311-requests-toolbelt",
"description": "Collection of utilities for python-requests"
},
{
"name": "py311-requests-unixsocket",
"description": "HTTP via a UNIX domain socket"
},
{
"name": "py311-requests_ntlm",
"description": "NTLM authentication support for Requests"
},
{
"name": "py311-requestsexceptions",
"description": "A simple library to find the correct path to exceptions in the requests library regardless of whether they are bundled."
},
{
"name": "py311-resampy",
"description": "Efficient sample rate conversion in python"
},
{
"name": "py311-resolvelib",
"description": "ResolveLib at the highest level provides a Resolver class that includes dependency resolution logic."
},
{
"name": "py311-responses",
"description": "A utility library for mocking out the requests library"
},
{
"name": "py311-resumable-urlretrieve",
"description": "Small library to fetch files over HTTP and resuming their download"
},
{
"name": "py311-retrying",
"description": "General-purpose retrying library for Python"
},
{
"name": "py311-rfc3339-validator",
"description": "A pure python RFC3339 validator"
},
{
"name": "py311-rfc3986",
"description": "A Python implementation of RFC 3986 including validation and authority parsing."
},
{
"name": "py311-rfc3986-validator",
"description": "A pure python RFC3986 validator"
},
{
"name": "py311-rfc3987-syntax",
"description": "Helper functions to parse and validate the syntax of terms defined in RFC 3987 — the IETF standard for Internationalized Resource Identifiers (IRIs)."
},
{
"name": "py311-rfc6555",
"description": "Python implementation of RFC 6555."
},
{
"name": "py311-rich",
"description": "Python library for rich text and beautiful formatting in the terminal"
},
{
"name": "py311-rich-argparse",
"description": "Format argparse and optparse help using rich"
},
{
"name": "py311-rich-click",
"description": "Format click help output nicely with rich"
},
{
"name": "py311-rich-theme-manager",
"description": "Manage rich themes for CLI applications"
},
{
"name": "py311-rich_rst",
"description": "reStructuredText renderer for rich"
},
{
"name": "py311-rlpycairo",
"description": "This is a plugin for the ReportLab PDF Toolkit."
},
{
"name": "py311-robotframework",
"description": "ATDD framework"
},
{
"name": "py311-robotremoteserver",
"description": "Remote server hosting test libraries"
},
{
"name": "py311-roman",
"description": "Integer to Roman numerals converter"
},
{
"name": "py311-roman_numerals",
"description": "Manipulate well-formed Roman numerals"
},
{
"name": "py311-roman_numerals_py",
"description": "Obsolete port, replaced by py311-roman_numerals"
}
]
}