GET /api/v1/autocomplete/port/?format=api&page=487
HTTP 200 OK
Allow: GET, HEAD, OPTIONS
Content-Type: application/json
Vary: Accept

{
    "count": 42552,
    "next": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=488",
    "previous": "https://ports.macports.org/api/v1/autocomplete/port/?format=api&page=486",
    "results": [
        {
            "name": "py310-requests_ntlm",
            "description": "NTLM authentication support for Requests"
        },
        {
            "name": "py310-requestsexceptions",
            "description": "A simple library to find the correct path to exceptions in the requests library regardless of whether they are bundled."
        },
        {
            "name": "py310-resampy",
            "description": "Efficient sample rate conversion in python"
        },
        {
            "name": "py310-resolvelib",
            "description": "ResolveLib at the highest level provides a Resolver class that includes dependency resolution logic."
        },
        {
            "name": "py310-responses",
            "description": "A utility library for mocking out the requests library"
        },
        {
            "name": "py310-resumable-urlretrieve",
            "description": "Small library to fetch files over HTTP and resuming their download"
        },
        {
            "name": "py310-retrying",
            "description": "General-purpose retrying library for Python"
        },
        {
            "name": "py310-rfc3339-validator",
            "description": "A pure python RFC3339 validator"
        },
        {
            "name": "py310-rfc3986",
            "description": "A Python implementation of RFC 3986 including validation and authority parsing."
        },
        {
            "name": "py310-rfc3986-validator",
            "description": "A pure python RFC3986 validator"
        },
        {
            "name": "py310-rfc3987-syntax",
            "description": "Helper functions to parse and validate the syntax of terms defined in RFC 3987 — the IETF standard for Internationalized Resource Identifiers (IRIs)."
        },
        {
            "name": "py310-rfc6555",
            "description": "Python implementation of RFC 6555."
        },
        {
            "name": "py310-rich",
            "description": "Python library for rich text and beautiful formatting in the terminal"
        },
        {
            "name": "py310-rich-click",
            "description": "Format click help output nicely with rich"
        },
        {
            "name": "py310-rich-theme-manager",
            "description": "Manage rich themes for CLI applications"
        },
        {
            "name": "py310-rich_rst",
            "description": "reStructuredText renderer for rich"
        },
        {
            "name": "py310-robotframework",
            "description": "ATDD framework"
        },
        {
            "name": "py310-roman",
            "description": "Integer to Roman numerals converter"
        },
        {
            "name": "py310-rope",
            "description": "python refactoring library"
        },
        {
            "name": "py310-rpds-py",
            "description": "Python bindings to Rust's persistent data structures (rpds)"
        },
        {
            "name": "py310-rply",
            "description": "pure Python parser generator"
        },
        {
            "name": "py310-rsa",
            "description": "Pure Python RSA implementation"
        },
        {
            "name": "py310-rsgislib",
            "description": "Python 3.10 bindings for RSGISlib - Remote Sensing and GIS Library"
        },
        {
            "name": "py310-rtree",
            "description": "R-Tree spatial index for Python GIS"
        },
        {
            "name": "py310-ruamel-yaml",
            "description": "YAML 1.2 loader/dumper package for Python"
        },
        {
            "name": "py310-ruamel-yaml-clib",
            "description": "the C based reader/scanner and emitter for ruamel.yaml"
        },
        {
            "name": "py310-rubicon-objc",
            "description": "Rubicon-ObjC is a bridge between Objective-C and Python"
        },
        {
            "name": "py310-rustworkx",
            "description": "A high performance Python graph library implemented in Rust"
        },
        {
            "name": "py310-s3fs",
            "description": "Convenient Filesystem interface over S3"
        },
        {
            "name": "py310-s3transfer",
            "description": "An Amazon S3 Transfer Manager"
        },
        {
            "name": "py310-sacrebleu",
            "description": "Hassle-free computation of shareable, comparable, and reproducible BLEU, chrF, and TER scores"
        },
        {
            "name": "py310-sacremoses",
            "description": "Python port of Moses tokenizer, truecaser and normalizer"
        },
        {
            "name": "py310-safetensors",
            "description": "Fast and Safe Tensor serialization"
        },
        {
            "name": "py310-samplerate",
            "description": "Monolithic python wrapper for libsamplerate based on pybind11 and NumPy"
        },
        {
            "name": "py310-sarif-om",
            "description": "Classes implementing the SARIF 2.1.0 object model."
        },
        {
            "name": "py310-sarpy",
            "description": "Tools to read, write, and process complex SAR data and associated data."
        },
        {
            "name": "py310-scamper",
            "description": "Python 3.10 bindings for scamper"
        },
        {
            "name": "py310-scapy",
            "description": "A powerful packet manipulation tool"
        },
        {
            "name": "py310-scikit-build",
            "description": "Improved build system generator for CPython extensions."
        },
        {
            "name": "py310-scikit-build-core",
            "description": "A bridge between Python package build systems and CMake (a rewrite of the classic Scikit-build)."
        },
        {
            "name": "py310-scikit-dsp-comm",
            "description": "A collection of functions and classes to support signal processing and communications theory teaching and research"
        },
        {
            "name": "py310-scikit-hep-awkward",
            "description": "Awkward Array is a library for nested, variable-sized data."
        },
        {
            "name": "py310-scikit-hep-awkward1",
            "description": "Awkward Array is a library for nested, variable-sized data."
        },
        {
            "name": "py310-scikit-hep-boost-histogram",
            "description": "Python bindings for Boost::Histogram."
        },
        {
            "name": "py310-scikit-hep-hepstats",
            "description": "Statistical modeling for HEP."
        },
        {
            "name": "py310-scikit-hep-hepunits",
            "description": "Collects the most commonly used units and constants in the HEP System of Units."
        },
        {
            "name": "py310-scikit-hep-hist",
            "description": "Hist is a analyst friendly front-end for boost-histogram."
        },
        {
            "name": "py310-scikit-hep-mplhep",
            "description": "A set of helpers for matplotlib to more easily produce plots typically needed in HEP."
        },
        {
            "name": "py310-scikit-hep-mplhep_data",
            "description": "Sub-package to hold data (fonts) for mplhep."
        },
        {
            "name": "py310-scikit-hep-particle",
            "description": "Particle provides a pythonic interface to the Particle Data Group (PDG) data."
        }
    ]
}